Home page

C4 Electrical

Code 43 (1/4)
 8/11/19 5:58am
CurtSutherly
Standard Member
Send Private Message

Steelton, PA - USA

Vette(s):
1992 white roadster, removable glass top, red leather.


Joined: 7/8/2019
Posts: 4

Hi, all . . .

I tried to post this several weeks ago, but my entire message simply vanished. So let's try this again . . .

In December 2017 I bought a 1992 Vette, white with red leather, 63,000 miles. Love the car! Or a least I did, until recently.

Some months ago, I began getting an SES light at cold engine start, in conjunction with the cooling fans coming on. But when the engine temp came up, the fans would shut down and the SES go off. At no time did the car run abnormally! Perfect performance, perfect acceleration! I bought an OBD-1 code reader and came up with Code 43, spark control. I had my mechanic replace both of the knock sensors. We also replaced the coolant switch and coolant temperature sensor. But the minute we started the car, the SES was back on, as were the fans. Only this time they did not turn off, but stayed on continually! Again, however, the car otherwise continued to perform perfectly. (The fan operation, I have since learned, is a function of the Code 43, which, along with the engine going limp mode . . . which mine does not . . . is intended to try and prevent serious engine damage.) My mechanic checked the wire continuity from the knock sensors to the Electronic Control Module and that checked okay. I have since had the ECM bench tested at a specialty shop, and they said they found several breaks in the solder consistent with the problem I have been having, and repaired those breaks. The ECM was in fact just returned to me two days ago. Yesterday I reinstalled the ECM, reconnected the battery, and started the engine. Once more, the fans came on followed by the SES. Same code . . . Code 43. Frankly, I am at my wits end! My next and last hope is to try and locate a technician somewhere within my home area who has a thorough knowledge of these systems. But if anyone reading this post has ever experienced anything similar to this, please let me know.

Curt Sutherly

Our Sponsors help support C4VR
Sponsor Ad

Re: Code 43 (2/4)
 8/11/19 10:27am
Adams' Apple
Standard Member
Moderator
Send Private Message

Duncanville, TX - USA

Vette(s):
1985 Coupe-L98/Auto,Bright Red/Carmine. 1974 Coupe-L48/4speed, Medium Red Metallic/Black Deluxe.


Joined: 3/18/2009
Posts: 2135

Are you certain there is no actual engine knock when starting? These engines have a tendency for piston slap to be pretty loud when cold. That being said, I have cured that same code by replacing the ECM on more than one occasion after exhausting every other avenue. Be aware tho, the reman/rebuilt ECMS do not normally come with a new PROM chip, so you have to use the old one....which is useless if the PROM is actually bad, and causing the 43 code to start with. Not sure if the '92 models still used the separate PROM in the ECM or not off-hand. If yours does not, then you may well be looking at replacing the ECM, even tho someone has already "fixed" it.

 

Circuit Description
The knock sensor system is used to detect engine detonation. The ECM will retard the spark timing based on a signal being received from the knock sensor. The knock sensors produce an AC voltage which the ECM detects. The AC voltage produced depends on the severity of the knock. A resistor to ground within each knock sensor causes the ECM's 5 volt "bias" to drop, so that under a no knock condition CKT 496 should measure about 1.5 volts. Since the sensors are connected in parallel, if one or the other sensor or circuits is open or disconnected, the voltage in circuit 496 will be greater than 1.5 volts but less than 5.0 volts, under a no-knock condition.


Test Description
Numbers below refer to circled numbers on the diagnostic chart.
1.  With engine idling, there should be NO knock signal present at the ECM, because detonation is not likely under no load condition.
2.  Tapping on the engines right or left exhaust manifold should simulate a knock signal to determine if the sensors are capable of detecting detonation. If no knock is detected, try tapping on engine block closer to sensors before replacing a sensor.
3.  If the engine has an internal mechanical problem which is creating a knock, the knock sensor may be responding to that condition.
4.  This test determines if the knock sensor is faulty or if the ESC portion of the MEM-CAL is faulty. If it is determined that the MEM-CAL is faulty, be sure that it is properly installed and latched into place. If not properly install, repair and retest.

Diagnostic Aids
While observing knock signal on the Tech 1, there should be an indication that knock is present when detonation can be heard. Detonation is most likely to occur under high engine load conditions.

 



|UPDATED|8/11/2019 7:27:46 AM (AZT)|/UPDATED|


______________
Joel Adams  
My Link

 
   
(click for Texas-sized view!)             NCRS

"Money can't buy happiness -- but somehow it's more comforting to cry in a CORVETTE than in a Kia"
Re: Code 43 (3/4)
 8/12/19 8:44am
CurtSutherly
Standard Member
Send Private Message

Steelton, PA - USA

Vette(s):
1992 white roadster, removable glass top, red leather.


Joined: 7/8/2019
Posts: 4

Thanks for responding!

The ECM for 1992-1993 Corvettes does indeed have a removable PROM, and I am leaning in the same direction as you . . . that the PROM itself may be faulty. I have found a place online where they make replacement (or clone) PROMs specific to your car based on a four-letter code located on the cover of the ECM. Cost is about $50, so it is not a killer price. As for replacing the entire ECM, I was going to do, so but quickly found that new modules for the '92-'93 Vettes are impossible to find. Even remanufactured ECMs are hard to find. I called at least six different companies, including Zip-Corvette, Corvette America, and Ecklers . . . only to have them all tell me that my best bet was to have my own unit repaired. I am going to call the company that did the ECM repair (SIA Electronics) and find out if they actually bench-tested the unit with my PROM installed. I don't believe they did . . . if I understand correctly, they removed the PROM while working on the actual module, and then installed a PROM of their own to do the final bench testing.

As for engine knock on startup, my lifters do indeed rap a bit due to the aluminum valve covers used that year, but no more so than previously, at least not to my ear. Also, my mechanic has not noticed anything unusual. That said, the knock system is not supposed to respond to anything during idle, only when the engine is under load. Nonetheless, next time I fire it up, I am going to listen more closely. I am also going to call an outfit in Reading, PA today (Stoudt Auto Sales) and ask some questions. They sell and service all era Corvettes so someone there may have some answers. I may also schedule an appointment to have them look at the car directly. My regular mechanic, Rob, is fantastic but is not fully versed on these older Corvettes, a thing he readily admits. I will keep you posted on what I find, and feel free to respond with any additional thoughts . . .

 

Re: Code 43 (4/4)
 8/12/19 9:48pm
Adams' Apple
Standard Member
Moderator
Send Private Message

Duncanville, TX - USA

Vette(s):
1985 Coupe-L98/Auto,Bright Red/Carmine. 1974 Coupe-L48/4speed, Medium Red Metallic/Black Deluxe.


Joined: 3/18/2009
Posts: 2135

If you do happen to go the route of changing the PROM, I would suggest/recommend go ahead and get an aftermarket deal, such as something from Hypertech. They offer both a "stock" style that has some minor upgrades, and and they have the "ThermoMaster" that allows the use of a lower temp thermostat, and it boosts the overall power at full throttle. I have the ThermoMaster chip in my '85 that's been in it since '97, and I've had no issues with it at all, but I did have to replace the ECM for other issues, keeping the Hypertech chip in it. They are a little more expensive than $50, but well worth it if you like to mash the go pedal every now and then. lol

EST/ESC codes can be a pain to resolve, since there are so many components that can cause a problem, including a bad/marginal ignition module. Only thing you can do is go thru the troubleshooting tree, and test each individual component according to the factory tests. Time consuming, but eventually, the real issue will be found, whatever it is.  Good luck with it, and be sure to let us know if/when you do find the problem. Of course, you can always ask any questions you have here, and we'll do the best we can to help. 👍



|UPDATED|8/12/2019 6:48:13 PM (AZT)|/UPDATED|


______________
Joel Adams  
My Link

 
   
(click for Texas-sized view!)             NCRS

"Money can't buy happiness -- but somehow it's more comforting to cry in a CORVETTE than in a Kia"