Home page

Topic: Blower motor runs on High constantly

in Forum: C4 Cooling and Heating Systems


Already a Member?
Login
Not yet a Member?
Register for Free!

Blower motor runs on High constantly (1/4)
 9/6/22 3:46pm
elvis628
Standard Member
Send Private Message

Nassau, NY - USA

Vette(s):
1996 Convertible - White w/black ragtop


Joined: 9/6/2022
Posts: 3

Another issue with my '96: Heater Control Module stopped working. Bought and installed a new (used) one; worked first off then blower began blowing on High and all controls stopped working.  Then replaced the Resistor Relay under the hood, per forums read (and advice of our mechanic) but didn't change anything. All fuses inside car are good. Have unhooked the blower for now until I can solve the issue.  Suggestions for next steps?

Our Sponsors help support C4VR
Re: Blower motor runs on High constantly (2/4)
 9/6/22 9:42pm
Adams' Apple
Standard Member
Moderator
Send Private Message

Duncanville, TX - USA

Vette(s):
1985 Coupe-L98/Auto,Bright Red/Carmine. 1974 Coupe-L48/4speed, Medium Red Metallic/Black Deluxe.


Joined: 3/18/2009
Posts: 2196

Does it just blow all the time, anytime the key is on? Sounds like there might be a ground issue that could be damaging the module. 



______________

Joel Adams  
My Link

 
   
(click for Texas-sized view!)             NCRS

"Money can't buy happiness -- but somehow it's more comforting to cry in a CORVETTE than in a Kia"

Re: Blower motor runs on High constantly (3/4)
 9/6/22 11:09pm
elvis628
Standard Member
Send Private Message

Nassau, NY - USA

Vette(s):
1996 Convertible - White w/black ragtop


Joined: 9/6/2022
Posts: 3

Yes, when the key is on.  I've read in some forums that people have an issue whereby their blower runs constant even with the key off! As mentioned, I've now unplugged it under the hood until I get it figured out. Will probably pull the control module again to check out the wiring.

Re: Blower motor runs on High constantly (4/4)
 Yesterday 9:37pm
Dave91TM
Standard Member
Send Private Message

Joined: 6/17/2012
Posts: 23

My blower motor was running full with the key out, I replaced the control module with a part from New Rockies. Lasted about 8 months and issue reappeared. I read up on it and a worn out blower motor can overload the module, so really both the module and motor should be replaced at the same time. Suggest check the blower motor and the housing, mine has a drain tube on the bottom which was full of dirt. 

 



______________
Our Sponsors help support C4VR