Home page

Forum: C4 Cooling and Heating Systems

Topic: Climate Controle Module Issue

Climate Controle Module Issue (1/3)
 5/19/20 9:25pm
TomLathen
Standard Member
Send Private Message

Roland, IA - USA

Vette(s):
1993 40th Anniversary Edition Coupé.


Joined: 5/19/2020
Posts: 1

I have a 1993 (40th Anniversary Edition) Corvette Coupe.  This morning, when I went to adjust the temperature in my air conditioning down a bit, when I depressed the "down arrow," absolutely nothing happened.  When I depressed the "up arrow," the temperature increased in single digit increments like it is supposed to.  Unfortunately, while messing with it, I now have my temperature set at maximum, which is 90 degrees.  Not good this time of the year!  Has anyone experienced this problem?  Any thoughts on how to rectify the situation.  Thanks!

Our Sponsors help support C4VR
Re: Climate Controle Module Issue (2/3)
 5/20/20 1:58pm
aldocar
Standard Member
Send Private Message

Joined: 12/3/2016
Posts: 85

On my 1988 I had an issue where I could not get my cool button to work I sent the unit out at a cost of 100 dollars and the company fixed the issue.  There are many videos on how to clean the contacts.  Take care and stay safe.



______________

 

Re: Climate Controle Module Issue (3/3)
 6/2/20 2:16pm
Corveddie
Standard Member
Send Private Message

Beacon, NY - USA

Vette(s):
1994 convertible, arctic white, black top and interior. LT1 auto.


Joined: 11/29/2009
Posts: 31

Bottom line:  You have to remove the HVAC head control unit, disassemble, and clean the button contacts which are located on a circuit board.
First video shows how to do it, second shows a more direct route for removing the HVAC head control unit.

https://www.youtube.com/watch?v=KBeqA1n9q9A

https://www.youtube.com/watch?v=qCjbEx4-iXE

 

Good luck!

Corveddie

Our Sponsors help support C4VR