Home page

Cool! NEW FEATURE! Add "Your Corvette Story" today

C4 Cooling and Heating Systems

Old-New to me vette-cooling fan (can't figure out) (1/2)
 8/8/18 4:49pm
BigDogYoop
Standard Member
Send Private Message

Sault Sainte Marie, MI - USA

Vette(s):
1984 coupe, auto, 80K


Joined: 8/8/2018
Posts: 2

Hello All, new to forum, but was reading some post's and seem's like a good group, so I'll ask for help, before I loose whats left of my brain.
1. just bought this clean 80K 1984 (2 weeks ago)
2. cooling fan was not coming on-so looked and seen fan sensor on passenger side melted.
3. ordered new low temp switch on 195 off 180 and 180 T-stat 
4. installed new relay and connector
5. Fan runs all the time with key ON-not started-and all time after started
6. waiting on Manual (shipping)
7. with fan on all time runs down road @184-5, but want system correct and just can't tell what to do next, any direction would really be appreciated, Thanks

**and with key on and I unplug fan switch (pass side of block) fan keeps running !!!
Our Sponsors help support C4VR
Sponsor Ad

Re: Old-New to me vette-cooling fan (can't figure out) (2/2)
 8/11/18 1:32am
Hot Rod Roy
Standard Member
Send Private Message

Mission Viejo, CA - USA

Vette(s):
Yellow '84 Coupe


Joined: 3/18/2015
Posts: 74

BigDogYoop said:
2. cooling fan was not coming on-so looked and seen fan sensor on passenger side melted.
3. ordered new low temp switch on 195 off 180 and 180 T-stat

So you replaced the CTS (Coolant Temp Switch)?

4. installed new relay and connector.

How did you determine the relay needed to be replaced?

5. Fan runs all the time with key ON-not started-and all time after started

**and with key on and I unplug fan switch (pass side of block) fan keeps running !!!

That's an indication there is a short circuit to ground in the sensor wire.   Is there a possibility the PO installed a switch to be able to turn the fan on at any time?




______________