Home page

Cool! NEW FEATURE! Add "Your Corvette Story" today

C4 Fuel, Emission Control, and Exhaust Systems

My 1990 will not go into closed loop (1/2)
 6/2/19 3:16am
GARY 53
Standard Member
Send Private Message

, - United Kingdom

Vette(s):
My c4 1990 is a euro model in pearlescent white with steel blue leather power seats I have own her for just under 4 years


Joined: 10/7/2015
Posts: 8

My 1990 will not go into closed loop i have scanned it and it is showing there are no codes/faults.
The oxygen sensor was reading 408 mVolts, engine temp 203.0, Oil Temp 193.5.
Manifold air Temp 134.6. Throttle sensor Voltage 0.54.
And the 02 sensor cross count was 0 with the oxygen sensor not ready.
I have Hedman hedders with the 02 sensor fitted to the collector by the no7 tube
the 02 sensor was changed last service i think the 02 sensor is not reaching 600.
Because of where 02 sensor is mounted would a heated 02 sensor solve the problem ?
your advise would be welcome

Our Sponsors help support C4VR
Sponsor Ad

Re: My 1990 will not go into closed loop (2/2)
 6/2/19 9:29am
Adams' Apple
Standard Member
Moderator
Send Private Message

Duncanville, TX - USA

Vette(s):
1985 Coupe-L98/Auto,Bright Red/Carmine. 1974 Coupe-L48/4speed, Medium Red Metallic/Black Deluxe.


Joined: 3/18/2009
Posts: 2127

GARY 53 said:

the 02 sensor was changed last service 


Did the system work before changing the O2 sensor? If so, then the sensor is the problem. New doesn't always mean good.

If you had the same issue before the sensor change, then I would say that you do need to re-position the sensor closer to the head, or rig up a heated sensor. With engine temps in the 200f range, and no closed loop operation, I'm surprised there are no codes...



______________
Joel Adams  
My Link

 
   
(click for Texas-sized view!)             NCRS

"Money can't buy happiness -- but somehow it's more comforting to cry in a CORVETTE than in a Kia"