Home page

Forum: C4 Interior

Topic: !994 Gague Cluster

!994 Gague Cluster (1/7)
 9/26/11 10:53am
John R
Standard Member
Send Private Message

Gloucester, MA - USA

Vette(s):
1994 Converible Polo Green


Joined: 9/25/2011
Posts: 10

I have no LCD display, cleaned  the conector to the Lcd ,where I had a couple of circuit that were open, Cleaned and repaired and still no display. If no answer Who and whear Can I get a replacement ?
Our Sponsors help support C4VR
Re: !994 Gague Cluster (2/7)
 9/26/11 12:34pm
Bob Cheek
Former Member

Send Private Message

Joined: 6/9/2011
Posts: 22

Before I went looking for a new Gauge Cluster, I would check the Central Control Module (CCM) for codes.  The only tool you need to get the codes is a bent paper clip.  If there isn't a post on this site for getting the codes try this link:

http://www.neilkline.com/Tech%20Tips/obdcodes.htm

A service manual wouldn't be a bad idea either.    I have a '94 and the complete GM manual so if you need some pages copied let me know, I'll scan and send them. 

There is a lot of diagnostic information collected by the CCM.  I had a code on my '94 that turned out to be where the previous owner installed a aftermarked stereo and the LCD power circuit was left open.  The CCM detected no power being pulled on that line a gave me a code and a recurring "SYS" display on the LCD.  A couple of 1K ohm resistors to simulate the load fixed that nicely. 

Bob
'94 Polo Green Metallic Coupe




______________

Bob - '94 Polo Green Coupe

Road Atlanta
 
Re: 94 Gague Cluster (3/7)
 9/26/11 3:48pm
John R
Standard Member
Send Private Message

Gloucester, MA - USA

Vette(s):
1994 Converible Polo Green


Joined: 9/25/2011
Posts: 10

Thanks Bob same color but its a convertible
Am I  going to need a code reader for this?  Wich I do not have, and I have the complet Manual.
 
 
Thanks John  
Re: !994 Gague Cluster (4/7)
 9/26/11 7:17pm
Bob Cheek
Former Member

Send Private Message

Joined: 6/9/2011
Posts: 22

Is the LCD displaying anything?  Or is it completely blank? 

Go to the Electrical Diagnosis section of the service manual and look up the section on the instrument cluster.  There is also a description in there about how to retrieve the codes from the CCM.  But if the display is completely blank that won't work because the codes are displayed on the LCD section of the instrument cluster.  

If the cluster is completely blank it makes me think there is a cable connector parted some where or the cluster is not getting power.  You can follow the troubleshooting chart in the Service Manual to determine what is not working. 

Bob
'94 Polo Green Metallic



______________

Bob - '94 Polo Green Coupe

Road Atlanta
 
Re: !994 Gague Cluster (5/7)
 9/26/11 7:17pm
Bob Cheek
Former Member

Send Private Message

Joined: 6/9/2011
Posts: 22

Oh, and you don't need a code reader.  

______________

Bob - '94 Polo Green Coupe

Road Atlanta
 
Re: !994 Gague Cluster (6/7)
 2/13/20 9:40pm
SETXvettvet
Standard Member
Send Private Message


Vette(s):
1994 C4 Coupe black in color with tan and black interior


Joined: 2/13/2020
Posts: 2

https://www.youtube.com/watch?v=Xm1FkPd2h3E

Re: !994 Gague Cluster (7/7)
 6/16/20 6:17pm
Our-83
Standard Member
Send Private Message

Saint Cloud, FL - USA

Vette(s):
1983


Joined: 1/10/2018
Posts: 4

Contact this guy - you may well need to have it partially or fully rebuilt. At the least it sounds like you will need some parts. 

He’s about to rebuild my 83’s

Been doing this for decades 

here’s from a listing for his service :

Please see my other listing for related dash cluster parts, I've been selling cluster parts on ebay for over 16years and rebuilding clusters for over 20 years. 

 

I also provide complete 1984-89 cluster rebuild service using only NEW Lcd's

 

Jim 9783354096  info/tech support

Our Sponsors help support C4VR